当前位置:首页>淘股论坛
到 页  
末页下一页上一页首页1/1页

用公式判断选股公式是否正确

淘股吧原创: 火红的烙铁   2015-03-15 12:17 只看楼主(-1)    浏览/回复693/0
最近学通达信的公式,希望能找出一个队选股结果进行判断的公式。
[淘股吧]
原创的,包括注释。

XGTJ:=TJ1 && TJ2 && TJ3 && TJ4; {选股条件由多个字条件组成}
INTJ:=XGTJ && NOT(REF(XGTJ,1)); {买入条件:上一次满足选股条件至今大于3天}

ZFTJ1:=(H-REF(C,1))/REF(C,1) 0.03; {最大涨幅大于3%}
SUC1:=REF(INTJ, 1) && ZFTJ1; {盈利条件:一日前的买入条件成立,且当日涨幅大于3%}

ZFTJ2:=(H-REF(C,3))/REF(C,3) 0.1; {三日涨幅大于10%}
SUC2:=REF(INTJ, 3) && ZFTJ2; {盈利条件:三日前的买入条件成立,且三日涨幅大于10%}

{参数N: 统计天数, 20~200, 60}
CNT0:=COUNT(INTJ, X); {N天内满足买入条件的次数}
CNT1:=COUNT(SUC1, X); {N天内满足盈利条件的次数}
CNT2:=COUNT(SUC2, X); {N天内满足盈利条件的次数};

{满足买入条件的次数不为0,达到盈利预期的次数占比大于80%}
(CNT0 0) && ((CNT1/CNT0 = 0.8) || (CNT2/CNT0 = 0.8)); {最终选出的股票集合}

{满足买入条件的次数不为0,达到盈利预期的次数占比不到80%}
(CNT0 0) && ((CNT1/CNT0 0.8) && (CNT2/CNT0 0.8));{最终选出的股票集合}

相关股票:

关联标签:

相关报告:

到 页  
末页下一页上一页首页1/1页
还有更多精彩跟帖请用笔名 登录 浏览
快速 注册 或其他方式登录:
微信订阅
收起
查看对话  (12)
相关文章
查看更多
提示
确定要删除该回复吗?
同时将此用户拉入黑名单
取消提交