当前位置:首页>淘股论坛
到 页  
末页下一页上一页首页1/1页

龙方龙方龙方

淘股吧原创: 风痕铭川   2015-01-09 15:25 只看楼主(-1)   浏览/回复691/0
       {易摆指标72}
[淘股吧]
C172:=(REF((C+H+L+O)/4,1)+EMA(REF(C,1),(72)))/2;
HAC172:=((C+H+L+O)/4+C172+HHV(H,C172)+LLV(L,C172))/4;
HAC72:=(EMA(HAC172,72/1.6)-EMA(EMA(HAC172,72/1.6),72/1.6))+EMA(EMA(EMA(HAC172,72/1.6),72/1.6),72/1.6);
VAVE72:=REF(MA(V/10000,(72))*SQRT(SQRT(72)),1);
VMAX72:=VAVE72*SQRT(SQRT(72));
VCR72:=IF(V/10000 VMAX72,V/10000,VMAX72);
VTR72:=S LOPE (V/10000,SQRT(72));
VTRT72:=(EMA(VTR72,3)-EMA(EMA(VTR72,3),3))+EMA(EMA(EMA(VTR72,3),3),3);
ERT72:=EVERY(VTRT72 REF(VTRT72,1),2) ;
SVA72:=(SUM(IF(HAC72 REF(HAC72,1) AND ERT72 ,VCR72,IF(HAC72 REF(HAC72,1) AND ERT72,-VCR72,0)),(SQRT(72))));
SVY72:=(EMA(SVA72,3)-EMA(EMA(SVA72,3),3))+EMA(EMA(EMA(SVA72,3),3),3);
C272:=(((((C+H+L+O)/4+C172+HHV(H,C172)+LLV(L,C172))/4)));
VAE72:=REF(MA(V/10000,SQRT(72)),1)*2;
VC72:=IF(V/10000 VAE72,V/10000,VAE72);
SVOPO72:=((SUM((IF(C272 REF(C272,1) AND (VTR72 REF(VTR72,1) ),VC72,IF(C272 REF(C272,1)AND (VTR72 REF(VTR72,1) ),-VC72,0))),(SQRT(72)))));
SVO72:=(EMA(SVOPO72,3)-EMA(EMA(SVOPO72,3),3))+EMA(EMA(EMA(SVOPO72,3),3),3);
易摆72:=(SVY72+SVO72)/2,COLORRED, LINE THICK3;
易度72:=(易摆72-REF(EMA(易摆72,72),72+1)),COLORGREEN,LINETHICK3;
C189:=(REF((C+H+L+O)/4,1)+EMA(REF(C,1),(89)))/2;
HAC189:=((C+H+L+O)/4+C189+HHV(H,C189)+LLV(L,C189))/4;
HAC89:=(EMA(HAC189,89/1.6)-EMA(EMA(HAC189,89/1.6),89/1.6))+EMA(EMA(EMA(HAC189,89/1.6),89/1.6),89/1.6);
VAVE89:=REF(MA(V/10000,(89))*SQRT(SQRT(89)),1);
VMAX89:=VAVE89*SQRT(SQRT(89));
VCR89:=IF(V/10000 VMAX89,V/10000,VMAX89);
VTR89:=SLOPE(V/10000,SQRT(89));
VTRT89:=(EMA(VTR89,3)-EMA(EMA(VTR89,3),3))+EMA(EMA(EMA(VTR89,3),3),3);
ERT89:=EVERY(VTRT89 REF(VTRT89,1),2) ;
SVA89:=(SUM(IF(HAC89 REF(HAC89,1) AND ERT89 ,VCR89,IF(HAC89 REF(HAC89,1) AND ERT89,-VCR89,0)),(SQRT(89))));
SVY89:=(EMA(SVA89,3)-EMA(EMA(SVA89,3),3))+EMA(EMA(EMA(SVA89,3),3),3);
C289:=(((((C+H+L+O)/4+C189+HHV(H,C189)+LLV(L,C189))/4)));
VAE89:=REF(MA(V/10000,SQRT(89)),1)*2;
VC89:=IF(V/10000 VAE89,V/10000,VAE89);
SVOPO89:=((SUM((IF(C289 REF(C289,1) AND (VTR89 REF(VTR89,1) ),VC89,IF(C289 REF(C289,1)AND (VTR89 REF(VTR89,1) ),-VC89,0))),(SQRT(89)))));
SVO89:=(EMA(SVOPO89,3)-EMA(EMA(SVOPO89,3),3))+EMA(EMA(EMA(SVOPO89,3),3),3);
易摆89:=(SVY89+SVO89)/2;
易度89:=(易摆89-REF(EMA(易摆89,89),89+1)),COLORGREEN;
C166:=(REF((C+H+L+O)/4,1)+EMA(REF(C,1),(66)))/2;
HAC166:=((C+H+L+O)/4+C166+HHV(H,C166)+LLV(L,C166))/4;
HAC66:=(EMA(HAC166,66/1.6)-EMA(EMA(HAC166,66/1.6),66/1.6))+EMA(EMA(EMA(HAC166,66/1.6),66/1.6),66/1.6);
VAVE66:=REF(MA(V/10000,(66))*SQRT(SQRT(66)),1);
VMAX66:=VAVE66*SQRT(SQRT(66));
VCR66:=IF(V/10000 VMAX66,V/10000,VMAX66);
VTR66:=SLOPE(V/10000,SQRT(66));
VTRT66:=(EMA(VTR66,3)-EMA(EMA(VTR66,3),3))+EMA(EMA(EMA(VTR66,3),3),3);
ERT66:=EVERY(VTRT66 REF(VTRT66,1),2) ;
SVA66:=(SUM(IF(HAC66 REF(HAC66,1) AND ERT66 ,VCR66,IF(HAC66 REF(HAC66,1) AND ERT66,-VCR66,0)),(SQRT(66))));
SVY66:=(EMA(SVA66,3)-EMA(EMA(SVA66,3),3))+EMA(EMA(EMA(SVA66,3),3),3);
C266:=(((((C+H+L+O)/4+C166+HHV(H,C166)+LLV(L,C166))/4)));
VAE66:=REF(MA(V/10000,SQRT(66)),1)*2;
VC66:=IF(V/10000 VAE66,V/10000,VAE66);
SVOPO66:=((SUM((IF(C266 REF(C266,1) AND (VTR66 REF(VTR66,1) ),VC66,IF(C266 REF(C266,1)AND (VTR66 REF(VTR66,1) ),-VC66,0))),(SQRT(66)))));
SVO66:=(EMA(SVOPO66,3)-EMA(EMA(SVOPO66,3),3))+EMA(EMA(EMA(SVOPO66,3),3),3);
易摆66:=(SVY66+SVO66)/2,COLORRED;
易度66:=(易摆66-REF(EMA(易摆66,66),66+1)),COLORGREEN;
C155:=(REF((C+H+L+O)/4,1)+EMA(REF(C,1),(55)))/2;
HAC155:=((C+H+L+O)/4+C155+HHV(H,C155)+LLV(L,C155))/4;
HAC55:=(EMA(HAC155,55/1.6)-EMA(EMA(HAC155,55/1.6),55/1.6))+EMA(EMA(EMA(HAC155,55/1.6),55/1.6),55/1.6);
VAVE55:=REF(MA(V/10000,(55))*SQRT(SQRT(55)),1);
VMAX55:=VAVE55*SQRT(SQRT(55));
VCR55:=IF(V/10000 VMAX55,V/10000,VMAX55);
VTR55:=SLOPE(V/10000,SQRT(55));
VTRT55:=(EMA(VTR55,3)-EMA(EMA(VTR55,3),3))+EMA(EMA(EMA(VTR55,3),3),3);
ERT55:=EVERY(VTRT55 REF(VTRT55,1),2) ;
SVA55:=(SUM(IF(HAC55 REF(HAC55,1) AND ERT55 ,VCR55,IF(HAC55 REF(HAC55,1) AND ERT55,-VCR55,0)),(SQRT(55))));
SVY55:=(EMA(SVA55,3)-EMA(EMA(SVA55,3),3))+EMA(EMA(EMA(SVA55,3),3),3);
C255:=(((((C+H+L+O)/4+C155+HHV(H,C155)+LLV(L,C155))/4)));
VAE55:=REF(MA(V/10000,SQRT(55)),1)*2;
VC55:=IF(V/10000 VAE55,V/10000,VAE55);
SVOPO55:=((SUM((IF(C255 REF(C255,1) AND (VTR55 REF(VTR55,1) ),VC55,IF(C255 REF(C255,1)AND (VTR55 REF(VTR55,1) ),-VC55,0))),(SQRT(55)))));
SVO55:=(EMA(SVOPO55,3)-EMA(EMA(SVOPO55,3),3))+EMA(EMA(EMA(SVOPO55,3),3),3);
易摆55:=(SVY55+SVO55)/2,COLORRED;
易度55:=(易摆55-REF(EMA(易摆55,55),55+1)),COLORGREEN;
C143:=(REF((C+H+L+O)/4,1)+EMA(REF(C,1),(43)))/2;
HAC143:=((C+H+L+O)/4+C143+HHV(H,C143)+LLV(L,C143))/4;
HAC43:=(EMA(HAC143,43/1.6)-EMA(EMA(HAC143,43/1.6),43/1.6))+EMA(EMA(EMA(HAC143,43/1.6),43/1.6),43/1.6);
VAVE43:=REF(MA(V/10000,(43))*SQRT(SQRT(43)),1);
VMAX43:=VAVE43*SQRT(SQRT(43));
VCR43:=IF(V/10000 VMAX43,V/10000,VMAX43);
VTR43:=SLOPE(V/10000,SQRT(43));
VTRT43:=(EMA(VTR43,3)-EMA(EMA(VTR43,3),3))+EMA(EMA(EMA(VTR43,3),3),3);
ERT43:=EVERY(VTRT43 REF(VTRT43,1),2) ;
SVA43:=(SUM(IF(HAC43 REF(HAC43,1) AND ERT43 ,VCR43,IF(HAC43 REF(HAC43,1) AND ERT43,-VCR43,0)),(SQRT(43))));
SVY43:=(EMA(SVA43,3)-EMA(EMA(SVA43,3),3))+EMA(EMA(EMA(SVA43,3),3),3);
C243:=(((((C+H+L+O)/4+C143+HHV(H,C143)+LLV(L,C143))/4)));
VAE43:=REF(MA(V/10000,SQRT(43)),1)*2;
VC43:=IF(V/10000 VAE43,V/10000,VAE43);
SVOPO43:=((SUM((IF(C243 REF(C243,1) AND (VTR43 REF(VTR43,1) ),VC43,IF(C243 REF(C243,1)AND (VTR43 REF(VTR43,1) ),-VC43,0))),(SQRT(43)))));
SVO43:=(EMA(SVOPO43,3)-EMA(EMA(SVOPO43,3),3))+EMA(EMA(EMA(SVOPO43,3),3),3);
易摆43:=(SVY43+SVO43)/2,COLORRED;
易度43:=(易摆43-REF(EMA(易摆43,43),43+1));
C181:=(REF((C+H+L+O)/4,1)+EMA(REF(C,1),(81)))/2;
HAC181:=((C+H+L+O)/4+C181+HHV(H,C181)+LLV(L,C181))/4;
HAC81:=(EMA(HAC181,81/1.6)-EMA(EMA(HAC181,81/1.6),81/1.6))+EMA(EMA(EMA(HAC181,81/1.6),81/1.6),81/1.6);
VAVE81:=REF(MA(V/10000,(81))*SQRT(SQRT(81)),1);
VMAX81:=VAVE81*SQRT(SQRT(81));
VCR81:=IF(V/10000 VMAX81,V/10000,VMAX81);
VTR81:=SLOPE(V/10000,SQRT(81));
VTRT81:=(EMA(VTR81,3)-EMA(EMA(VTR81,3),3))+EMA(EMA(EMA(VTR81,3),3),3);
ERT81:=EVERY(VTRT81 REF(VTRT81,1),2) ;
SVA81:=(SUM(IF(HAC81 REF(HAC81,1) AND ERT81 ,VCR81,IF(HAC81 REF(HAC81,1) AND ERT81,-VCR81,0)),(SQRT(81))));
SVY81:=(EMA(SVA81,3)-EMA(EMA(SVA81,3),3))+EMA(EMA(EMA(SVA81,3),3),3);
C281:=(((((C+H+L+O)/4+C181+HHV(H,C181)+LLV(L,C181))/4)));
VAE81:=REF(MA(V/10000,SQRT(81)),1)*2;
VC81:=IF(V/10000 VAE81,V/10000,VAE81);
SVOPO81:=((SUM((IF(C281 REF(C281,1) AND (VTR81 REF(VTR81,1) ),VC81,IF(C281 REF(C281,1)AND (VTR81 REF(VTR81,1) ),-VC81,0))),(SQRT(81)))));
SVO81:=(EMA(SVOPO81,3)-EMA(EMA(SVOPO81,3),3))+EMA(EMA(EMA(SVOPO81,3),3),3);
易摆81:=(SVY81+SVO81)/2;
易度81:=(易摆81-REF(EMA(易摆81,81),81+1));
C133:=(REF((C+H+L+O)/4,1)+EMA(REF(C,1),(33)))/2;
HAC133:=((C+H+L+O)/4+C133+HHV(H,C133)+LLV(L,C133))/4;
HAC33:=(EMA(HAC133,33/1.6)-EMA(EMA(HAC133,33/1.6),33/1.6))+EMA(EMA(EMA(HAC133,33/1.6),33/1.6),33/1.6);
VAVE33:=REF(MA(V/10000,(33))*SQRT(SQRT(33)),1);
VMAX33:=VAVE33*SQRT(SQRT(33));
VCR33:=IF(V/10000 VMAX33,V/10000,VMAX33);
VTR33:=SLOPE(V/10000,SQRT(33));
VTRT33:=(EMA(VTR33,3)-EMA(EMA(VTR33,3),3))+EMA(EMA(EMA(VTR33,3),3),3);
ERT33:=EVERY(VTRT33 REF(VTRT33,1),2) ;
SVA33:=(SUM(IF(HAC33 REF(HAC33,1) AND ERT33 ,VCR33,IF(HAC33 REF(HAC33,1) AND ERT33,-VCR33,0)),(SQRT(33))));
SVY33:=(EMA(SVA33,3)-EMA(EMA(SVA33,3),3))+EMA(EMA(EMA(SVA33,3),3),3);
C233:=(((((C+H+L+O)/4+C133+HHV(H,C133)+LLV(L,C133))/4)));
VAE33:=REF(MA(V/10000,SQRT(33)),1)*2;
VC33:=IF(V/10000 VAE33,V/10000,VAE33);
SVOPO33:=((SUM((IF(C233 REF(C233,1) AND (VTR33 REF(VTR33,1) ),VC33,IF(C233 REF(C233,1)AND (VTR33 REF(VTR33,1) ),-VC33,0))),(SQRT(33)))));
SVO33:=(EMA(SVOPO33,3)-EMA(EMA(SVOPO33,3),3))+EMA(EMA(EMA(SVOPO33,3),3),3);
易摆33:=(SVY33+SVO33)/2,COLORRED;
易度33:=(易摆33-REF(EMA(易摆33,33),33+1));
C121:=(REF((C+H+L+O)/4,1)+EMA(REF(C,1),(21)))/2;
HAC121:=((C+H+L+O)/4+C121+HHV(H,C121)+LLV(L,C121))/4;
HAC21:=(EMA(HAC121,21/1.6)-EMA(EMA(HAC121,21/1.6),21/1.6))+EMA(EMA(EMA(HAC121,21/1.6),21/1.6),21/1.6);
VAVE21:=REF(MA(V/10000,(21))*SQRT(SQRT(21)),1);
VMAX21:=VAVE21*SQRT(SQRT(21));
VCR21:=IF(V/10000 VMAX21,V/10000,VMAX21);
VTR21:=SLOPE(V/10000,SQRT(21));
VTRT21:=(EMA(VTR21,3)-EMA(EMA(VTR21,3),3))+EMA(EMA(EMA(VTR21,3),3),3);
ERT21:=EVERY(VTRT21 REF(VTRT21,1),2) ;
SVA21:=(SUM(IF(HAC21 REF(HAC21,1) AND ERT21 ,VCR21,IF(HAC21 REF(HAC21,1) AND ERT21,-VCR21,0)),(SQRT(21))));
SVY21:=(EMA(SVA21,3)-EMA(EMA(SVA21,3),3))+EMA(EMA(EMA(SVA21,3),3),3);
C221:=(((((C+H+L+O)/4+C121+HHV(H,C121)+LLV(L,C121))/4)));
VAE21:=REF(MA(V/10000,SQRT(21)),1)*2;
VC21:=IF(V/10000 VAE21,V/10000,VAE21);
SVOPO21:=((SUM((IF(C221 REF(C221,1) AND (VTR21 REF(VTR21,1) ),VC21,IF(C221 REF(C221,1)AND (VTR21 REF(VTR21,1) ),-VC21,0))),(SQRT(21)))));
SVO21:=(EMA(SVOPO21,3)-EMA(EMA(SVOPO21,3),3))+EMA(EMA(EMA(SVOPO21,3),3),3);
易摆21:=(SVY21+SVO21)/2,COLORRED;
易度21:=(易摆21-REF(EMA(易摆21,21),21+1));
C113:=(REF((C+H+L+O)/4,1)+EMA(REF(C,1),(13)))/2;
HAC113:=((C+H+L+O)/4+C113+HHV(H,C113)+LLV(L,C113))/4;
HAC13:=(EMA(HAC113,13/1.6)-EMA(EMA(HAC113,13/1.6),13/1.6))+EMA(EMA(EMA(HAC113,13/1.6),13/1.6),13/1.6);
VAVE13:=REF(MA(V/10000,(13))*SQRT(SQRT(13)),1);
VMAX13:=VAVE13*SQRT(SQRT(13));
VCR13:=IF(V/10000 VMAX13,V/10000,VMAX13);
VTR13:=SLOPE(V/10000,SQRT(13));
VTRT13:=(EMA(VTR13,3)-EMA(EMA(VTR13,3),3))+EMA(EMA(EMA(VTR13,3),3),3);
ERT13:=EVERY(VTRT13 REF(VTRT13,1),2) ;
SVA13:=(SUM(IF(HAC13 REF(HAC13,1) AND ERT13 ,VCR13,IF(HAC13 REF(HAC13,1) AND ERT13,-VCR13,0)),(SQRT(13))));
SVY13:=(EMA(SVA13,3)-EMA(EMA(SVA13,3),3))+EMA(EMA(EMA(SVA13,3),3),3);
C213:=(((((C+H+L+O)/4+C113+HHV(H,C113)+LLV(L,C113))/4)));
VAE13:=REF(MA(V/10000,SQRT(13)),1)*2;
VC13:=IF(V/10000 VAE13,V/10000,VAE13);
SVOPO13:=((SUM((IF(C213 REF(C213,1) AND (VTR13 REF(VTR13,1) ),VC13,IF(C213 REF(C213,1)AND (VTR13 REF(VTR13,1) ),-VC13,0))),(SQRT(13)))));
SVO13:=(EMA(SVOPO13,3)-EMA(EMA(SVOPO13,3),3))+EMA(EMA(EMA(SVOPO13,3),3),3);
易摆13:=(SVY13+SVO13)/2,COLORRED;
易度13:=(易摆13-REF(EMA(易摆13,13),13+1));
易摆:=(易摆13+易摆21+易摆33+易摆43+易摆55+易摆66+易摆72+易摆89+易摆81)/9,COLORRED;
易度:=(易度13+易度21+易度33+易度43+易度55+易度66+易度72+易度89+易度81)/9,COLORGREEN;
TD指数:=(H-MAX(REF(H,1),REF(H,2)))+((L-MIN(REF(L,1),REF(L,2))));
TD膨胀:=IF((H =REF(L,4)) OR (H =REF(L,5)) OR (MAX(REF(H,1),REF(H,2)) =REF(C,6)) OR (MAX(REF(H,1),REF(H,2)) =REF(C,7)) ,TD指数,0);
TD72:=MA(SUM(TD膨胀,72)/(HHV(H,72)-LLV(L,72))*100,2);{钱龙多方}
TD66:=MA(SUM(TD膨胀,66)/(HHV(H,66)-LLV(L,66))*100,2);
TD55:=MA(SUM(TD膨胀,55)/(HHV(H,55)-LLV(L,55))*100,2);
TD43:=MA(SUM(TD膨胀,43)/(HHV(H,43)-LLV(L,43))*100,2);
TD33:=MA(SUM(TD膨胀,33)/(HHV(H,33)-LLV(L,33))*100,2);
TD21:=MA(SUM(TD膨胀,21)/(HHV(H,21)-LLV(L,21))*100,2);
TD13:=MA(SUM(TD膨胀,13)/(HHV(H,13)-LLV(L,13))*100,2);
TD8:=MA(SUM(TD膨胀,8)/(HHV(H,8)-LLV(L,8))*100,2);
幅度:=(TD8+TD13+TD21+TD33+TD43+TD55+TD66+TD72)/8;
VPCI72:=((SUM(C*V/10000,72)/SUM(V/10000,72))-MA(C,72))*((SUM(C*V/10000,SQRT(72))/SUM(V/10000,SQRT(72)))/MA(C,SQRT(72)))*(MA(V/10000,SQRT(72))/MA(V/10000,72));
VPCI66:=((SUM(C*V/10000,66)/SUM(V/10000,66))-MA(C,66))*((SUM(C*V/10000,SQRT(66))/SUM(V/10000,SQRT(66)))/MA(C,SQRT(66)))*(MA(V/10000,SQRT(66))/MA(V/10000,66));
VPCI55:=((SUM(C*V/10000,55)/SUM(V/10000,55))-MA(C,55))*((SUM(C*V/10000,SQRT(55))/SUM(V/10000,SQRT(55)))/MA(C,SQRT(55)))*(MA(V/10000,SQRT(55))/MA(V/10000,55));
VPCI33:=((SUM(C*V/10000,33)/SUM(V/10000,33))-MA(C,33))*((SUM(C*V/10000,SQRT(33))/SUM(V/10000,SQRT(33)))/MA(C,SQRT(33)))*(MA(V/10000,SQRT(33))/MA(V/10000,33));
VPCI21:=((SUM(C*V/10000,21)/SUM(V/10000,21))-MA(C,21))*((SUM(C*V/10000,SQRT(21))/SUM(V/10000,SQRT(21)))/MA(C,SQRT(21)))*(MA(V/10000,SQRT(21))/MA(V/10000,21));
VPCI13:=((SUM(C*V/10000,13)/SUM(V/10000,13))-MA(C,13))*((SUM(C*V/10000,SQRT(13))/SUM(V/10000,SQRT(13)))/MA(C,SQRT(13)))*(MA(V/10000,SQRT(13))/MA(V/10000,13));
VPCI43:=((SUM(C*V/10000,43)/SUM(V/10000,43))-MA(C,43))*((SUM(C*V/10000,SQRT(43))/SUM(V/10000,SQRT(43)))/MA(C,SQRT(43)))*(MA(V/10000,SQRT(43))/MA(V/10000,43));
VPCI8:=((SUM(C*V/10000,8)/SUM(V/10000,8))-MA(C,8))*((SUM(C*V/10000,SQRT(8))/SUM(V/10000,SQRT(8)))/MA(C,SQRT(8)))*(MA(V/10000,SQRT(8))/MA(V/10000,8));
VPCI37:=((SUM(C*V/10000,37)/SUM(V/10000,37))-MA(C,37))*((SUM(C*V/10000,SQRT(37))/SUM(V/10000,SQRT(37)))/MA(C,SQRT(37)))*(MA(V/10000,SQRT(37))/MA(V/10000,37));
确认:=100*(VPCI13+VPCI21+VPCI33+VPCI55+VPCI43+VPCI72+VPCI66+VPCI8+VPCI37)/9;
DAIB:=(H+L+C)/3;
流量:=DAIB*V;
ZJ1:=IF(流量-REF(流量,1) 0,(流量-REF(流量,1)),0);
ZJ2:=IF(流量-REF(流量,1) 0,(REF(流量,1)-流量),0);
比率72:=(SUM(ZJ1,(72))/SUM(ZJ2,(72)));
金72:=(100-(100/(1+比率72)))*1-50;
金72SQ:=MA(金72,(72));
比率55:=(SUM(ZJ1,(55))/SUM(ZJ2,(55)));
金55:=(100-(100/(1+比率55)))*1-50;
金55SQ:=MA(金55,(55));
比率33:=(SUM(ZJ1,(33))/SUM(ZJ2,(33)));
金33:=(100-(100/(1+比率33)))*1-50;
金33SQ:=MA(金33,(33));
比率13:=(SUM(ZJ1,(13))/SUM(ZJ2,(13)));
金13:=(100-(100/(1+比率13)))*1-50;
金13SQ:=MA(金13,(13));
比率21:=(SUM(ZJ1,(21))/SUM(ZJ2,(21)));
金21:=(100-(100/(1+比率21)))*1-50;
金21SQ:=MA(金21,(21));
比率43:=(SUM(ZJ1,(43))/SUM(ZJ2,(43)));
金43:=(100-(100/(1+比率43)))*1-50;
金43SQ:=MA(金43,(43));
比率66:=(SUM(ZJ1,(66))/SUM(ZJ2,(66)));
金66:=(100-(100/(1+比率66)))*1-50;
金66SQ:=MA(金66,(66));
比率:=(金72SQ+金66SQ+金55SQ+金43SQ+金33SQ+金21SQ+金13SQ)/7;
AL1:=IF(C OPEN ,V/10000,0);{侦察指数}
AL2:=IF(C OPEN,V/10000,0);
PVII72:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,72),1)+REF(MA(AL1,72),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,72),1)+REF(MA(AL2,72),1)*(C-REF(C,1))/REF(C,1)),1/2*SQRT(72)),LINETHICK2;
PVIIY72:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,72),1)+REF(MA(AL1,72),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,72),1)+REF(MA(AL2,72),1)*(C-REF(C,1))/REF(C,1)),72),LINETHICK1;
PVII55:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,55),1)+REF(MA(AL1,55),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,55),1)+REF(MA(AL2,55),1)*(C-REF(C,1))/REF(C,1)),1/2*SQRT(55)),LINETHICK2;
PVIIY55:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,55),1)+REF(MA(AL1,55),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,55),1)+REF(MA(AL2,55),1)*(C-REF(C,1))/REF(C,1)),55),LINETHICK1;
PVII43:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,43),1)+REF(MA(AL1,43),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,43),1)+REF(MA(AL2,43),1)*(C-REF(C,1))/REF(C,1)),1/2*SQRT(43)),LINETHICK1;
PVIIY43:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,43),1)+REF(MA(AL1,43),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,43),1)+REF(MA(AL2,43),1)*(C-REF(C,1))/REF(C,1)),43),LINETHICK2;
PVII33:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,33),1)+REF(MA(AL1,33),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,33),1)+REF(MA(AL2,33),1)*(C-REF(C,1))/REF(C,1)),1/2*SQRT(33)),LINETHICK1;
PVIIY33:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,33),1)+REF(MA(AL1,33),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,33),1)+REF(MA(AL2,33),1)*(C-REF(C,1))/REF(C,1)),33),LINETHICK2;
PVII21:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,21),1)+REF(MA(AL1,21),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,21),1)+REF(MA(AL2,21),1)*(C-REF(C,1))/REF(C,1)),1/2*SQRT(21)),LINETHICK1;
PVIIY21:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,21),1)+REF(MA(AL1,21),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,21),1)+REF(MA(AL2,21),1)*(C-REF(C,1))/REF(C,1)),21),LINETHICK2;
PVII13:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,13),1)+REF(MA(AL1,13),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,13),1)+REF(MA(AL2,13),1)*(C-REF(C,1))/REF(C,1)),1/2*SQRT(13)),LINETHICK1;
PVIIY13:=MA(IF(V/10000 REF(V/10000,1),REF(MA(AL1,13),1)+REF(MA(AL1,13),1)*(C-REF(C,1))/REF(C,1),REF(MA(AL2,13),1)+REF(MA(AL2,13),1)*(C-REF(C,1))/REF(C,1)),13),LINETHICK2;
侦察:=(PVIIY13+PVIIY21+PVIIY33+PVIIY43+PVIIY55+PVIIY72)/7/2+(MA((PVII13+PVII21+PVII33+PVII43+PVII55+PVII72)/7,8))/2;
TQ72:=72*MA(((MA(V/10000,72)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,72))),SQRT(72))*1000,COLORGREEN,LINETHICK1;
T72:=72*MA(((MA(V/10000,72)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,72))),72)*1000,COLORBLUE,LINETHICK2;
TQ55:=55*MA(((MA(V/10000,55)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,55))),SQRT(55))*1000,COLORGREEN,LINETHICK1;
T55:=55*MA(((MA(V/10000,55)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,55))),55)*1000,COLORBLUE,LINETHICK2;
TQ33:=33*MA(((MA(V/10000,33)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,33))),SQRT(33))*1000,COLORGREEN,LINETHICK1;
T33:=33*MA(((MA(V/10000,33)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,33))),33)*1000,COLORBLUE,LINETHICK2;
TQ13:=13*MA(((MA(V/10000,13)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,13))),SQRT(13))*1000,COLORGREEN,LINETHICK1;
T13:=13*MA(((MA(V/10000,13)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,13))),13)*1000,COLORBLUE,LINETHICK2;
TQ21:=21*MA(((MA(V/10000,21)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,21))),SQRT(21))*1000,COLORGREEN,LINETHICK1;
T21:=21*MA(((MA(V/10000,21)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,21))),21)*1000,COLORBLUE,LINETHICK2;
TQ43:=43*MA(((MA(V/10000,43)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,43))),SQRT(43))*1000,COLORGREEN,LINETHICK1;
T43:=43*MA(((MA(V/10000,43)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,43))),43)*1000,COLORBLUE,LINETHICK2;
TQ66:=66*MA(((MA(V/10000,66)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,66))),SQRT(66))*1000,COLORGREEN,LINETHICK1;
T66:=66*MA(((MA(V/10000,66)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,66))),66)*1000,COLORBLUE,LINETHICK2;
TQ8:=8*MA(((MA(V/10000,8)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,8))),SQRT(8))*1000,COLORGREEN,LINETHICK1;
T8:=8*MA(((MA(V/10000,8)-((2*(C-L)/(MAX(H,REF(C,1))-MIN(L,REF(C,1)))))-1))/((SUM(V/10000,8))),8)*1000,COLORBLUE,LINETHICK2;
{资流指数}
特威:=(T13+T21+T33+T43+T55+T66+T72)/8/2+MA((TQ13+TQ21+TQ33+TQ43+TQ55+TQ66+TQ72)/8,2)/2;
RCLA72:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(72));
RCLD72:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),(72));
RCLE72:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(72));
RCLF72:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),55);
RCL72:=(RCLA72+RCLD72)/2;
RCLEF72:=(RCLE72+RCLF72)/2;
TRA72:=MA(MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW)),(72));
HD72:=HIGH-REF(HIGH,1);
LD72:=REF(LOW,1)-LOW;
DMP72:=MA(IF(HD72 0 AND HD72 LD72,HD72,0),(72));
DMM72:=MA(IF(LD72 0 AND LD72 HD72,LD72,0),(72));
PDI72:=DMP72*100/TRA72;
MDI72:=DMM72*100/TRA72;
ADXM72:=(ABS(MDI72-PDI72)/(MDI72+PDI72)*100);
CMP72:=SUM(C-REF(C,1),72)/SUM(C+REF(C,1),72)*10000;
UMP72:=SUM(IF((H+C+L) =REF((H+C+L),1),1,-1),72)*10;
RNB72:=SUM((CLOSE-OPEN)/(HIGH-LOW),72)*10;
JAI72:=(CMP72+UMP72+RNB72)/3;
JA72:=SQRT(ABS((CMP72+UMP72+RNB72)/3));
钱72:=10*MA(IF(RCL72 =0 ,RCL72*SQRT(ABS(JA72)*TRA72*ADXM72),-ABS(RCL72)*SQRT(ABS(JA72)*TRA72*ADXM72)),2)*100;
RCLA55:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(55));
RCLD55:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),(55));
RCLE55:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(55));
RCLF55:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),55);
RCL55:=(RCLA55+RCLD55)/2;
RCLEF55:=(RCLE55+RCLF55)/2;
TRA55:=MA(MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW)),(55));
HD55:=HIGH-REF(HIGH,1);
LD55:=REF(LOW,1)-LOW;
DMP55:=MA(IF(HD55 0 AND HD55 LD55,HD55,0),(55));
DMM55:=MA(IF(LD55 0 AND LD55 HD55,LD55,0),(55));
PDI55:=DMP55*100/TRA55;
MDI55:=DMM55*100/TRA55;
ADXM55:=(ABS(MDI55-PDI55)/(MDI55+PDI55)*100);
CMP55:=SUM(C-REF(C,1),55)/SUM(C+REF(C,1),55)*10000;
UMP55:=SUM(IF((H+C+L) =REF((H+C+L),1),1,-1),55)*10;
RNB55:=SUM((CLOSE-OPEN)/(HIGH-LOW),55)*10;
JAI55:=(CMP55+UMP55+RNB55)/3;
JA55:=SQRT(ABS((CMP55+UMP55+RNB55)/3));
钱55:=10*MA(IF(RCL55 =0 ,RCL55*SQRT(ABS(JA55)*TRA55*ADXM55),-ABS(RCL55)*SQRT(ABS(JA55)*TRA55*ADXM55)),2)*100;
RCLA43:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(43));
RCLD43:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),(43));
RCLE43:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(43));
RCLF43:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),43);
RCL43:=(RCLA43+RCLD43)/2;
RCLEF43:=(RCLE43+RCLF43)/2;
TRA43:=MA(MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW)),(43));
HD43:=HIGH-REF(HIGH,1);
LD43:=REF(LOW,1)-LOW;
DMP43:=MA(IF(HD43 0 AND HD43 LD43,HD43,0),(43));
DMM43:=MA(IF(LD43 0 AND LD43 HD43,LD43,0),(43));
PDI43:=DMP43*100/TRA43;
MDI43:=DMM43*100/TRA43;
ADXM43:=(ABS(MDI43-PDI43)/(MDI43+PDI43)*100);
CMP43:=SUM(C-REF(C,1),43)/SUM(C+REF(C,1),43)*10000;
UMP43:=SUM(IF((H+C+L) =REF((H+C+L),1),1,-1),43)*10;
RNB43:=SUM((CLOSE-OPEN)/(HIGH-LOW),43)*10;
JAI43:=(CMP43+UMP43+RNB43)/3;
JA43:=SQRT(ABS((CMP43+UMP43+RNB43)/3));
钱43:=10*MA(IF(RCL43 =0 ,RCL43*SQRT(ABS(JA43)*TRA43*ADXM43),-ABS(RCL43)*SQRT(ABS(JA43)*TRA43*ADXM43)),2)*100;
RCLA33:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(33));
RCLD33:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),(33));
RCLE33:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(33));
RCLF33:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),33);
RCL33:=(RCLA33+RCLD33)/2;
RCLEF33:=(RCLE33+RCLF33)/2;
TRA33:=MA(MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW)),(33));
HD33:=HIGH-REF(HIGH,1);
LD33:=REF(LOW,1)-LOW;
DMP33:=MA(IF(HD33 0 AND HD33 LD33,HD33,0),(33));
DMM33:=MA(IF(LD33 0 AND LD33 HD33,LD33,0),(33));
PDI33:=DMP33*100/TRA33;
MDI33:=DMM33*100/TRA33;
ADXM33:=(ABS(MDI33-PDI33)/(MDI33+PDI33)*100);
CMP33:=SUM(C-REF(C,1),33)/SUM(C+REF(C,1),33)*10000;
UMP33:=SUM(IF((H+C+L) =REF((H+C+L),1),1,-1),33)*10;
RNB33:=SUM((CLOSE-OPEN)/(HIGH-LOW),33)*10;
JAI33:=(CMP33+UMP33+RNB33)/3;
JA33:=SQRT(ABS((CMP33+UMP33+RNB33)/3));
钱33:=10*MA(IF(RCL33 =0 ,RCL33*SQRT(ABS(JA33)*TRA33*ADXM33),-ABS(RCL33)*SQRT(ABS(JA33)*TRA33*ADXM33)),2)*100;
RCLA21:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(21));
RCLD21:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),(21));
RCLE21:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(21));
RCLF21:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),21);
RCL21:=(RCLA21+RCLD21)/2;
RCLEF21:=(RCLE21+RCLF21)/2;
TRA21:=MA(MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW)),(21));
HD21:=HIGH-REF(HIGH,1);
LD21:=REF(LOW,1)-LOW;
DMP21:=MA(IF(HD21 0 AND HD21 LD21,HD21,0),(21));
DMM21:=MA(IF(LD21 0 AND LD21 HD21,LD21,0),(21));
PDI21:=DMP21*100/TRA21;
MDI21:=DMM21*100/TRA21;
ADXM21:=(ABS(MDI21-PDI21)/(MDI21+PDI21)*100);
CMP21:=SUM(C-REF(C,1),21)/SUM(C+REF(C,1),21)*10000;
UMP21:=SUM(IF((H+C+L) =REF((H+C+L),1),1,-1),21)*10;
RNB21:=SUM((CLOSE-OPEN)/(HIGH-LOW),21)*10;
JAI21:=(CMP21+UMP21+RNB21)/3;
JA21:=SQRT(ABS((CMP21+UMP21+RNB21)/3));
钱21:=10*MA(IF(RCL21 =0 ,RCL21*SQRT(ABS(JA21)*TRA21*ADXM21),-ABS(RCL21)*SQRT(ABS(JA21)*TRA21*ADXM21)),2)*100;
RCLA13:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(13));
RCLD13:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),(13));
RCLE13:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(13));
RCLF13:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),13);
RCL13:=(RCLA13+RCLD13)/2;
RCLEF13:=(RCLE13+RCLF13)/2;
TRA13:=MA(MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW)),(13));
HD13:=HIGH-REF(HIGH,1);
LD13:=REF(LOW,1)-LOW;
DMP13:=MA(IF(HD13 0 AND HD13 LD13,HD13,0),(13));
DMM13:=MA(IF(LD13 0 AND LD13 HD13,LD13,0),(13));
PDI13:=DMP13*100/TRA13;
MDI13:=DMM13*100/TRA13;
ADXM13:=(ABS(MDI13-PDI13)/(MDI13+PDI13)*100);
CMP13:=SUM(C-REF(C,1),13)/SUM(C+REF(C,1),13)*10000;
UMP13:=SUM(IF((H+C+L) =REF((H+C+L),1),1,-1),13)*10;
RNB13:=SUM((CLOSE-OPEN)/(HIGH-LOW),13)*10;
JAI13:=(CMP13+UMP13+RNB13)/3;
JA13:=SQRT(ABS((CMP13+UMP13+RNB13)/3));
钱13:=10*MA(IF(RCL13 =0 ,RCL13*SQRT(ABS(JA13)*TRA13*ADXM13),-ABS(RCL13)*SQRT(ABS(JA13)*TRA13*ADXM13)),2)*100;
RCLA66:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(66));
RCLD66:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),(66));
RCLE66:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),4*SQRT(66));
RCLF66:=MA((CLOSE-REF(CLOSE,1))*SUM(V/10000,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100),66);
RCL66:=(RCLA66+RCLD66)/2;
RCLEF66:=(RCLE66+RCLF66)/2;
TRA66:=MA(MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW)),(66));
HD66:=HIGH-REF(HIGH,1);
LD66:=REF(LOW,1)-LOW;
DMP66:=MA(IF(HD66 0 AND HD66 LD66,HD66,0),(66));
DMM66:=MA(IF(LD66 0 AND LD66 HD66,LD66,0),(66));
PDI66:=DMP66*100/TRA66;
MDI66:=DMM66*100/TRA66;
ADXM66:=(ABS(MDI66-PDI66)/(MDI66+PDI66)*100);
CMP66:=SUM(C-REF(C,1),66)/SUM(C+REF(C,1),66)*10000;
UMP66:=SUM(IF((H+C+L) =REF((H+C+L),1),1,-1),66)*10;
RNB66:=SUM((CLOSE-OPEN)/(HIGH-LOW),66)*10;
JAI66:=(CMP66+UMP66+RNB66)/3;
JA66:=SQRT(ABS((CMP66+UMP66+RNB66)/3));
钱66:=10*MA(IF(RCL66 =0 ,RCL66*SQRT(ABS(JA66)*TRA66*ADXM66),-ABS(RCL66)*SQRT(ABS(JA66)*TRA66*ADXM66)),2)*100;
HHK:=(钱72+钱66+钱55+钱43+钱33+钱21+钱13);

AR72:=SUM(HIGH-OPEN,72)/SUM(OPEN-LOW,72)*100;
AR66:=SUM(HIGH-OPEN,66)/SUM(OPEN-LOW,66)*100;
AR55:=SUM(HIGH-OPEN,55)/SUM(OPEN-LOW,55)*100;
AR43:=SUM(HIGH-OPEN,43)/SUM(OPEN-LOW,43)*100;
AR33:=SUM(HIGH-OPEN,33)/SUM(OPEN-LOW,33)*100;
AR21:=SUM(HIGH-OPEN,21)/SUM(OPEN-LOW,21)*100;
AR13:=SUM(HIGH-OPEN,13)/SUM(OPEN-LOW,13)*100;

ARD:=(AR13+AR21+AR33+AR43+AR55+AR66+AR72)/7;
TH72:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),72);
TL72:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),72);
TW72:=SUM(IF(CLOSE=REF(CLOSE,1),V/10000,0),72);
VR72:=100*(TH72*2+TW72)/(TL72*2+TW72);
TH66:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),66);
TL66:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),66);
TW66:=SUM(IF(CLOSE=REF(CLOSE,1),V/10000,0),66);
VR66:=100*(TH66*2+TW66)/(TL66*2+TW66);
TH55:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),55);
TL55:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),55);
TW55:=SUM(IF(CLOSE=REF(CLOSE,1),V/10000,0),55);
VR55:=100*(TH55*2+TW55)/(TL55*2+TW55);
TH43:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),43);
TL43:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),43);
TW43:=SUM(IF(CLOSE=REF(CLOSE,1),V/10000,0),43);
VR43:=100*(TH43*2+TW43)/(TL43*2+TW43);
TH33:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),33);
TL33:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),33);
TW33:=SUM(IF(CLOSE=REF(CLOSE,1),V/10000,0),33);
VR33:=100*(TH33*2+TW33)/(TL33*2+TW33);
TH21:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),21);
TL21:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),21);
TW21:=SUM(IF(CLOSE=REF(CLOSE,1),V/10000,0),21);
VR21:=100*(TH21*2+TW21)/(TL21*2+TW21);
TH13:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),13);
TL13:=SUM(IF(CLOSE REF(CLOSE,1),V/10000,0),13);
TW13:=SUM(IF(CLOSE=REF(CLOSE,1),V/10000,0),13);
VR13:=100*(TH13*2+TW13)/(TL13*2+TW13);
VRD:=(VR13+VR21+VR33+VR43+VR55+VR66+VR72)/7;
BR72:=SUM(MAX(0,HIGH-REF(CLOSE,1)),72)/SUM(MAX(0,REF(CLOSE,1)-LOW),72)*100;
BR66:=SUM(MAX(0,HIGH-REF(CLOSE,1)),66)/SUM(MAX(0,REF(CLOSE,1)-LOW),66)*100;
BR55:=SUM(MAX(0,HIGH-REF(CLOSE,1)),55)/SUM(MAX(0,REF(CLOSE,1)-LOW),55)*100;
BR43:=SUM(MAX(0,HIGH-REF(CLOSE,1)),43)/SUM(MAX(0,REF(CLOSE,1)-LOW),43)*100;
BR33:=SUM(MAX(0,HIGH-REF(CLOSE,1)),33)/SUM(MAX(0,REF(CLOSE,1)-LOW),33)*100;
BR21:=SUM(MAX(0,HIGH-REF(CLOSE,1)),21)/SUM(MAX(0,REF(CLOSE,1)-LOW),21)*100;
BR13:=SUM(MAX(0,HIGH-REF(CLOSE,1)),13)/SUM(MAX(0,REF(CLOSE,1)-LOW),13)*100;
BRD:=(BR13+BR21+BR33+BR43+BR55+BR66+BR72)/7;
CR72:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),72)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),72)*100;
CR66:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),66)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),66)*100;
CR55:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),55)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),55)*100;
CR43:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),43)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),43)*100;
CR33:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),33)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),33)*100;
CR21:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),21)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),21)*100;
CR13:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),13)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),13)*100;
CRD:=(CR13+CR21+CR33+CR43+CR55+CR66+CR72)/7;

龙方:=CRD 0 AND BRD 0 AND VRD 0 AND ARD 0 AND HHK 0 AND 幅度 0 AND 确认 0 AND 比率 0 AND 侦察 0 AND 特威 0 AND 易摆 REF(易摆,1) AND 易度 REF(易度,1) AND 易摆 0 AND 易度 0 ;


IF(龙方,1,DRAWNULL),CO LORL IGRAY,LINETHICK1;
IF(龙方,2,DRAWNULL),COLORLIGRAY,LINETHICK1;
IF(龙方,3,DRAWNULL),COLORLIGRAY,LINETHICK1;
IF(龙方,4,DRAWNULL),COLORLIGRAY,LINETHICK1;
IF(龙方,5,DRAWNULL),COLORLIGRAY,LINETHICK1;
IF(龙方,6,DRAWNULL),COLORLIGRAY,LINETHICK1;
IF(龙方,7,DRAWNULL),COLORLIGRAY,LINETHICK1;
IF(龙方,8,DRAWNULL),COLORLIGRAY,LINETHICK1;
IF(龙方,9,DRAWNULL),COLORLIGRAY,LINETHICK1;
IF(龙方,10,DRAWNULL),COLORLIGRAY,LINETHICK1;
DRAWTEXT(龙方,11,‘多‘);
IF(龙方 AND HHK REF(HHK,1),1,DRAWNULL),COLORM AGEN TA,LINETHICK1;
IF(龙方 AND 幅度 REF(幅度,1),2,DRAWNULL),COLORMA GENT A,LINETHICK1;
IF(龙方 AND 确认 REF(确认,1),3,DRAWNULL),COLORMAGENTA,LINETHICK1;
IF(龙方 AND 比率 REF(比率,1),4,DRAWNULL),COLORMAGENTA,LINETHICK1;
IF(龙方 AND 侦察 REF(侦察,1),5,DRAWNULL),COLORMAGENTA,LINETHICK1;
IF(龙方 AND 特威 REF(特威,1),6,DRAWNULL),COLORMAGENTA,LINETHICK1;
IF(龙方 AND ARD REF(ARD,1),8,DRAWNULL),COLORMAGENTA,LINETHICK1;
IF(龙方 AND BRD REF(BRD,1),7,DRAWNULL),COLORMAGENTA,LINETHICK1;
IF(龙方 AND CRD REF(CRD,1),9,DRAWNULL),COLORMAGENTA,LINETHICK1;
IF(龙方 AND VRD REF(VRD,1),10,DRAWNULL),COLORMAGENTA,LINETHICK1;

IF(龙方 AND HHK MA(HHK,72) AND MA(HHK,72) REF((HHK,72),1),1,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(龙方 AND 幅度 MA(幅度,72)AND MA(幅度,72) REF(MA(幅度,72),1),2,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(龙方 AND 确认 MA(确认,72)AND MA(确认,72) REF(MA(确认,72),1),3,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(龙方 AND 比率 MA(比率,72)AND MA(比率,72) REF(MA(比率,72),1),4,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(龙方 AND 侦察 MA(侦察,72)AND MA(侦察,72) REF(MA(侦察,72),1),5,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(龙方 AND 特威 MA(特威,72)AND MA(特威,72) REF(MA(特威,72),1),6,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(龙方 AND ARD MA(ARD,72)AND MA(ARD,72) REF((ARD,72),1),7,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(龙方 AND BRD MA(BRD,72)AND MA(BRD,72) REF((BRD,72),1),7,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(龙方 AND CRD MA(CRD,72)AND MA(CRD,72) REF((CRD,72),1),7,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(龙方 AND VRD MA(VRD,72)AND MA(VRD,72) REF((VRD,72),1),7,DRAWNULL),COLORYELLOW,LINETHICK1;

IF(龙方 AND HHK MA(HHK,72) AND MA(HHK,72) REF(MA(HHK,72),1) AND HHK REF(HHK,1),1,DRAWNULL),COLORRED,LINETHICK3;
IF(龙方 AND 幅度 MA(幅度,72)AND MA(幅度,72) REF(MA(幅度,72),1) AND 幅度 REF(幅度,1),2,DRAWNULL),COLORRED,LINETHICK3;
IF(龙方 AND 确认 MA(确认,72)AND MA(确认,72) REF(MA(确认,72),1) AND 确认 REF(确认,1),3,DRAWNULL),COLORRED,LINETHICK3;
IF(龙方 AND 比率 MA(比率,72)AND MA(比率,72) REF(MA(比率,72),1) AND 比率 REF(比率,1),4,DRAWNULL),COLORRED,LINETHICK3;
IF(龙方 AND 侦察 MA(侦察,72)AND MA(侦察,72) REF(MA(侦察,72),1) AND 侦察 REF(侦察,1),5,DRAWNULL),COLORRED,LINETHICK3;
IF(龙方 AND 特威 MA(特威,72)AND MA(特威,72) REF(MA(特威,72),1) AND 特威 REF(特威,1),6,DRAWNULL),COLORRED,LINETHICK3;
IF(龙方 AND ARD MA(ARD,72)AND MA(ARD,72) REF(MA(ARD,72),1) AND ARD REF(ARD,1),7,DRAWNULL),COLORRED,LINETHICK3;
IF(龙方 AND BRD MA(BRD,72)AND MA(BRD,72) REF(MA(BRD,72),1) AND BRD REF(BRD,1),8,DRAWNULL),COLORRED,LINETHICK3;
IF(龙方 AND CRD MA(CRD,72)AND MA(CRD,72) REF(MA(CRD,72),1) AND CRD REF(CRD,1),9,DRAWNULL),COLORRED,LINETHICK3;
IF(龙方 AND VRD MA(VRD,72)AND MA(VRD,72) REF(MA(VRD,72),1) AND VRD REF(VRD,1),10,DRAWNULL),COLORRED,LINETHICK3;


方1:= HHK MA(HHK,72) AND MA(HHK,72) REF(MA(HHK,72),1) AND HHK REF(HHK,1);
方2:= 幅度 MA(幅度,72)AND MA(幅度,72) REF(MA(幅度,72),1) AND 幅度 REF(幅度,1);
方3:= 确认 MA(确认,72)AND MA(确认,72) REF(MA(确认,72),1) AND 确认 REF(确认,1);
方4:= 比率 MA(比率,72)AND MA(比率,72) REF(MA(比率,72),1) AND 比率 REF(比率,1);
方5:= 侦察 MA(侦察,72)AND MA(侦察,72) REF(MA(侦察,72),1) AND 侦察 REF(侦察,1);
方6:= 特威 MA(特威,72)AND MA(特威,72) REF(MA(特威,72),1) AND 特威 REF(特威,1);
方7:= ARD MA(ARD,72)AND MA(ARD,72) REF(MA(ARD,72),1) AND ARD REF(ARD,1);
方8:= BRD MA(BRD,72)AND MA(BRD,72) REF(MA(BRD,72),1) AND BRD REF(BRD,1);
方9:= CRD MA(CRD,72)AND MA(CRD,72) REF(MA(CRD,72),1) AND CRD REF(CRD,1);
方0:= VRD MA(VRD,72)AND MA(VRD,72) REF(MA(VRD,72),1) AND VRD REF(VRD,1);

龙BA:龙方 AND 方1 AND 方2 AND 方3 AND 方4 AND 方5 AND 方6 AND 方7 AND 方8 AND 方9 AND 方0,COLORYELLOW;


DRAWTEXT(龙BA,12,‘1‘),COLORMAGENTA;
13;

相关股票: AGEN   GENT   LINE   LOPE   LORL   OPEN  

关联标签:

相关报告:

到 页  
末页下一页上一页首页1/1页
亲,夜深了,早点休息吧。
还有更多精彩跟帖请用笔名 登录 浏览
快速 注册 或其他方式登录:
微信订阅
收起
查看对话  (12)
相关文章
查看更多
提示
确定要删除该回复吗?
同时将此用户拉入黑名单
取消提交